Installing the Lenovo XClarity Administrator PowerShell toolkit

To use the Lenovo XClarity Administrator PowerShell (LXCAPSTool) toolkit, install the toolkit, and start a Microsoft PowerShell session. The PowerShell toolkit is included with the XClarity Administrator appliance and can be downloaded as described below.

Before you begin

Before installing the XClarity Administrator PowerShell toolkit, ensure that the local Microsoft Windows system meets the following prerequisites:
  • Microsoft .NET Framework 4.5 is installed. You can download Microsoft .NET Framework 4.5 from the Microsoft .NET Framework 4.5 webpage.
  • The local system has network connectivity to the XClarity Administrator management server.
  • You must be logged in as a user with administrator authority to install and uninstall the PowerShell toolkit

  • The XClarity Administrator PowerShell toolkit supports the following PowerShell versions (see the Installing PowerShell on Windows webpage.
    • XClarity Administrator v3.1 requires PowerShell 4, 5.1 or PowerShell Core 7.0.3 or later.

    • XClarity Administrator v3.0 requires PowerShell 3, 4, 5.1 or PowerShell Core 7.0.1 or later.

    • XClarity Administrator v2.8 requires PowerShell 3, 4, 5.1 or PowerShell Core 7.0.0 or later.

    • XClarity Administrator v2.7 and earlier requires PowerShell 3, 4, or 5.1.

    Note: PowerShell Core 7.0 is updated frequently by Microsoft. The XClarity Administrator PowerShell toolkit is aligned with the latest stable version of PowerShell that is available when the XClarity Administrator PowerShell toolkit version is released.

Procedure

What to do next